Java plugin needed message when connecting to a website

I had issue connecting to a broccade switch. I got a message that I need to install Java. But Java latest version is already installed on my system.

I tried to install an old version but I could not solve that.

I Found this on a website.

  1. Install Java Latest version 32bit (even if on a x64 box)
  2. Edit the Java.Security file and comment out (put a # sign in front)
    use notepad++ or any other text editor that allows proper formatting display

3. Do this for both java.security files if you have both 32 and 64 bit java installed. The file(s) are found at:
C:\Program Files (x86) \Java\jre7\lib\security
C:\Program Files\Java\jre7\lib\security

4. Open up control panel and lower the java security bar to medium

5. Add the URLS of your brocades into the Exception Site List (make sure this is identical to what you type into your browser or have bookmarked)

Link